Oct
26
2011

ACO5422E SMO error when connecting to SQL Server 2008 – tdpsql 5.5.1

While configuring TDP for SQL Server (v5.5.1) on a SQL Server 2008 R2, received following error:

Error:
While opening SQL Server using TDPSQL GUI (V5.5.1) ACO5422E Received the following from the MS SQL server:Could not load file or assembly ‘Microsoft.SqlServer.Smo, Version=9.0.242.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91′ or one of its dependencies. The system cannot find the file specified.

To Resolve the Issue found following IBM article,
https://www-304.ibm.com/support/docview.wss?uid=swg21455220

One more user article available at: http://www.sqldbadiaries.com/2010/12/20/could-not-load-file-or-assembly-error-while-using-tdp-makes-a-come-back/

Problem is:
Tivoli Data Protection for SQL fails with ACO5422E when connecting to SQL

Fix provided is:
The error is a Microsoft prerequisite error relating to SMO. Installing the SMO SDK from Microsoft on the SQL server will resolve the error. Refer to the Microsoft document:http://msdn.microsoft.com/en-us/library/ms162169.aspx

Solution Tried:
Tried to resolve issue by going to following link,
http://www.Microsoft.com/download/en/confirmation.aspx?id=16978

and downloaded Microsoft SQL Server 2008 R2 Shared Management Objects file SharedManagementObjects.msi

installed the 32 bit version (as SQL server is hosted on 32 bit OS)

It didn’t solved the issue, so I installed SMO version of SQL 2005 from following link,
http://www.microsoft.com/download/en/details.aspx?id=15748

After installing I received following error,
ACO5424E Could not connect to SQL Server; SQL Server Returned: Failed to connect to server xxxxxxxxx
This SQL Version (10.50) is not supported (Hresult: 0x80131501)

Final Verdict:
On research I found that tdp v 5.5.1 does not support SQL Server 2008 or 2008 R2, you need minimum Data Protection for SQL version 5.5.2 in order to operate with SQL Server 2008 / 2008 R2

Useful Info:
Starting with Tivoli Data Protection for SQL 5.5.2, the installation processing will automatically check that the prerequisite software exists on the machine. If not, a dialog box will display the necessary Microsoft packages that need to be installed. You will then have the option to let the Tivoli Data Protection perform the installation of the products or cancel and install the prerequisites manually.

Some useful links:
http://social.msdn.microsoft.com/forums/en-US/sqlsmoanddmo/thread/8fffee16-c71e-420d-b7ec-d3d80b8c4580/

TDPSQL 5.5.x Known issues
https://www-304.ibm.com/support/docview.wss?uid=swg21305911#General%20Issues%20and%20Limitations%20Re

Download PDF

Related Posts

About the Author: Nitin Garg

Indian born, trekker, biker, photographer, lover of monsoons... I love to blog the topics I research and find useful for self or online community to save time and energy :) Everything you read on my blog is my own personal opinion!

1 Comment + Add Comment

  • thanks!

Leave a comment

Subscribe to this blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 461 other subscribers

Translate this blog!

EnglishFrenchGermanItalianPortugueseRussianSpanish

Calender

September 2017
M T W T F S S
« May    
 123
45678910
11121314151617
18192021222324
252627282930  

View Post by Categories

%d bloggers like this: